• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Quad Newbie With Drone Issues

Kayaken

New Member
Hi all. I’m new to the site and fairly new to drones. I have a barebones drone with the following state:

- carbon frame
- individual esc wired to the pdb board
- omnibusf4 flight controller
- Flysky receiver

configuring with betaflight

Well before I started messing with settings in beta flight and running into issues. Before I started with the settings, when I plugged the drone into the laptop, I could connect and individually run the motors. Now, I can’t get the motors to spin using beta flight. Any help would approached. Thanks
 

Kayaken

New Member
One thing in particular that I'm not able to do is when I plug in my quad to Betaflight and go to the motors tab, click that I understand the risks, and slide the master throttle up, the motors do nothing. Shouldn't they motors start to work at that point?
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Hello Kayaken and welcome :). In beta flight, did you calibrate the motors first? If you didn't... you need to do that first. Make sure the blades are off! Then in the motor tab where the motor test mode/Arming notice...turn that on. Then slide the master all the way up. Then plug your battery in. You will here some kind of musical sounds. Wait till it's done then slide the master down. You will here musical sounds again. Your done. Unplug everything then power up the TX then the quad and see if that works. You also need to install BLHeli configuration. This will configure your esc. Hope that works for you. Let us know :).
 

Kayaken

New Member
Thanks d.o.g. For the reply. I followed the directions but did not hear any musical sounds.

downloaded blheli. What do I do with that? Should I read the setup and “flash all”?
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
OK then. Start from the beginning then. Tony, the owner of this site has a video you should check out first
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
I have the same FC and depending where you order it from, you might have to flash the latest firm ware too.
 

Kayaken

New Member
I watched both videos and I'm still lost as heck. Maybe I should start with what I have done so far. I've downloaded the drivers and bound the flight controller to the transmitter. As for configuration, this is what I have:

- Flysky FS-i6
- Receiver is a FS-iA6B
- Flight Controller is Omnibus F4 V5
- Battery is 1500 mAh LiPo 4s 14.8V. When i have it connected to Betaflight, the battery reads only ~4V after charging all night.

I'll add an image of the set up.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Kayaken. Can you make a video of the quad being powered up?. We need to here what's doing and sounding. I'm a spektrum user so I might be know help to you but other might. Be patience with the set up. BTW... very clean build you have their :). I'm not sure if this will help but here's the pinout for that FC omnibus pinout - Google Search
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Hey Kayaken. In the the receiver tab of betaflight, can you control the quad with the TX? You must be able move the sticks around and see movement on the betaflight screen. If not, you need to go to the port tab and find which UART is turn on. For me, using spektrum, I'm using UART 6. You also need to go into the modes tab in betaflight and have that set up so the quad can arm and disarm. I have Arm, Angle, Horizon and acro highlighted. You are so close. It's something silly but I'll try my best to help.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Hey Kayaken. In the the receiver tab of betaflight, can you control the quad with the TX? You must be able move the sticks around and see movement on the betaflight screen. If not, you need to go to the port tab and find which UART is turn on. For me, using spektrum, I'm using UART 6. You also need to go into the modes tab in betaflight and have that set up so the quad can arm and disarm. I have Arm, Angle, Horizon and acro highlighted. You are so close. It's something silly but I'll try my best to help.

I'm hoping that someone will chime in like Tony, if he's not busy. If you have time and don't mind, we can set up a Skype chat and I'll try to help you out. Almost seem like the proper firmware isn't updated. It's hard to tell. Don't give up hope, once you get her going...it will be a blast.
 

Kayaken

New Member
Also, would it help to buy a power supply to hook up in place of the battery pack? This way I can eliminate the battery as a factor?
 

Kayaken

New Member
DOGfirst, thanks for helping. Very grateful for you taking the time.

I went into beta flight and in the receiver tab, when I move the controls on the transmitter I do see the throttle and yaw bars move in response to the left control and the roll and pitch move with the right control.

in the modes tab, I have ARM, ANGLE, and HORIZON enabled as shown. They seem to be functional when I play with the SWA and SWC switch on the flysky transmitter. I’m not seeing the ACRO mode though. The remaining modes are headfree, fail safe, headadj, beeper, osd disable sw, blackbox, fpv angle mix, blackbox erase and camera control 1,2 and 3, prearm, vex pit mode, paralyze, acro trainer, and launch control. Is acro trainer what you are referring to?

I’m game for a call. I have WhatsApp if that works but can set up a Skype account. Let me know what works for you. Thanks again.
 

Attachments

  • 11920403-A9A1-4A4C-9EE6-2AA4042C317D.jpeg
    11920403-A9A1-4A4C-9EE6-2AA4042C317D.jpeg
    276.9 KB · Views: 2

D.O.G.

Well-Known Member
Goblin 380 Supporter
Yes this is very strange. Me being spektrum and you being flysky shouldn't make much of a difference. It's just RX connecting to TX. Hey, question here. It's not arming the motor which is telling me that you might not have the high and low throttle ends not set right...maybe. First, what esc are you using like one shot, D-shot, multi shot and so on. Go into configuration tab in beta flight. On the right side you will see esc/motor feature. Make sure you have the low, middle and high throttle end set correctly. I have my set to 1000 for low, 1500 for middle and 2000 for high. If these numbers don't match the numbers on receiver tab in beta flight...quad will not arm. Also on your receiver tab, make sure that every tab meet the same low, middle and high throttle tab that you have set. To me it seems that your are so close to arming this quad tat it's a number factor. Try that out first and let me know what happens. As for modes tab, those three are fine to get this quad flying. Let's first get you air Bourne first. It's my pleasure trying to help. Learning something new in this hobby. Wait till you want to fly helis...lol. Keep me posted and all things fail, we can skype.

Sorry for the late response:(. Sometime life gets in the way :).
 

Kayaken

New Member
No worries on the late response. I'm trying out suggestions every so often as I have a ton of other things going on as well. Life does get in the way!

So I checked the ESC's and they are Crazepony Flycolor BLHeli_S 30A ESC with Dshot 600. I noticed in Betaflight that I had it on Oneshot in the ESC /Motor Features section. Switched it over but no change. At least I can rule that factor out. I then went into the Motors Tab and checked the Yaw and Throttle. They are both set at Low of 1000, Mid of 1500, and high at 2000.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Checking in again to see if there are any other leads that may help.

OK. My question to you is your FC is SD or not? This will make a difference when your flash the firmware in betaflight. Other thing make sure that on the upper right, where it said com3, that must say DFU before you can install a firmware. Here's a app that you should install. ImpluseRC Driver fixer. This will automatically find out what FC you have and will put your FC into DFU. Then you have to pick your firmware version. I would start with the oldest version first. See if that will work. Keep us posted.
 

Kayaken

New Member
Hi DOG.
Couple of questions on your directions.
1. What do you mean by SD? Do I need to check the specs for the flight controller?
2. How do I know what firmware I need? Is it particular for the flight controller?

Thanks,
Ken
 

Top Bottom