• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Spektrum New Transmitter

MurryB

Member
Thanks to all of you. Went to spektrum they don't have anything for 7210, and that freakware sites wants $115.00 dollars. I think I am going to leave it as it is the firmware in it now is 4.1.5. Like you guys said I don't trust it if it is not from spektrum.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
I did the same thing. I didn't want to pay for it or go through a third party so I didn't bother to upgrade and just kept on flying with what I have :).
 

MurryB

Member
Well have 7210BX programed up to a point. Got to point were all servos work in same direction, but when I elv,ali. tried reversing the servos nothing works. Don't know what to do. Does anybody on here use the AR7210BX so i could see how you have it wired up, it is not the same as 7200.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Well have 7210BX programed up to a point. Got to point were all servos work in same direction, but when I elv,ali. tried reversing the servos nothing works. Don't know what to do. Does anybody on here use the AR7210BX so i could see how you have it wired up, it is not the same as 7200.
Have you tried reversing the two in the unit instead of the TX? I have my looking from back to front of Heli, I have Aux 1 as my PITT which is located on the right side of the heli and I have the AIL as my AIL which is located on the left of the Heli and ELE is ELE and so on. I hope this help some...maybe?
 

MurryB

Member
D.O.G. do you have the 7210? I swap wires around on the unit to, but didn't help anything
 
Last edited:

D.O.G.

Well-Known Member
Goblin 380 Supporter
D.O.G. do you have the 7210? I swap wires around on the unit to, but didn't help anything
My last poke at this will be start over again. Set up a new model in the TX and take it from there. I have nothing after that...sorry
 

MurryB

Member
Had to switch around on the main unit and finally got the right combo. All servos working in right direction now. I got as far as checking the cyclic at 6 degree and it is telling my set is wrong. I though those arms on the head had to be level. My 500 book says set the linkages 21mm from plastic to plastic which they are not. Will set them and see what happens. Do I need to use that governor setting in the set up?
 

MurryB

Member
Well have the first part of the setup done. I was wondering if you had to do the parameter menu settings. Haven't flown it yet, I have to charge some batteries. I didn't use the governor settings. I wanted the esc to do the work.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
That's great your getting closer. As to the parameter menu, my self, I would leave it alone for the time being. Especially if you haven't flown it yet.
 

Top Bottom