1. If you would like to get rid of these banners and the ads within the posts, all you have to do is sign up and they will go away!
  2. Welcome to Rc-Help, are you here looking for the PDF Plans? They are located in the store in the tab above, but you must be signed in to access that part of the site. It only takes a second to sign up!
  3. Like Us On Facebook!
    Hello Guest, it occurred to us during that last server failure that we had no way of informing the members of the site of the failure and I would like to invite you to like us on facebook so that you can get updates if the site happens to go down again. We don't post much over there unless we are updating the members so we will not flood your feed like some places do. Just click on Like and then allow notifications and that's it. See you there soon!

    Click Here To Rc-Help's Facebook page!
    Dismiss Notice
Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Quad Fly Egg 130 Not Connecting In Beta Flight

Discussion in 'Multi-Rotor' started by Chartz, Jun 21, 2018.

  1. Chartz

    Chartz New Member

    Joined:
    Jun 21, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Florida
    I am having a big problem trying to communicate with my Fly egg 130 in Betaflight 10.2.0 . I tried different cables and downloading all drivers via Betaflight. I can connect my Eachine wizard x220 no problem so I know its not the cables or drivers on my laptop
    Windows 10 keeps telling my it does not reconize the usb device attached. I am thinking its the controller board on the Fly Egg. I get the com blue light when the cable is connected also a green light keeps flashing which I dont know what that is . Dont even remember where I got the Fly Egg 130 from ? Just wondering if theres any thing I can do tried RC Impluse and it never finds the controller board it searches forever.

    Please if anyone can help I would be grateful

    Thanks
    Chartz
     


  2. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    This almost sounds like you turned off the USB in the Ports tab. Only way to recover that is to put it into boot mode and reflash the board. If that doesn't work, then the only other thing I know to do is order up a new board.
     
  3. Chartz

    Chartz New Member

    Joined:
    Jun 21, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Florida
    Thats what I thought not too sure how to put this model Fly Egg 130 in boot mode not a lot of info out there. Still searching
     
  4. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    There is a boot button on the flight controller. You will push and hold this as you plug in the battery and it will put it in DFU mode. Then, connect it to the computer and select firmware flash. Make sure it says DFU mode in the top right instead of COMx. And do not connect to it or try to connect to it.
     

Share This Page