• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

General E-Flight Draco non Spektrum

GoFlyBoy

New Member
Hi

My first electric plane. I need some help.

I have bought a Draco.
I use Futaba.

I installed my Futaba receiver. All controls work …… except the motor.

something is “chirping” all the time when I have power on. The motor turns slightly every time the things “chirps”

How do I get the motor to work.?
What Chanel should the “motor controller” be in ? 3 for Futaba?

thanks
 

RandyDSok

Well-Known Member
On Futaba... ch3 is the throttle for most ( if not all ) of their receivers.

You probably need to calibrate your throttle with the ESC/motor. This differs with each type/brand of ESC so you may want to look it up for yours if the following doesn't work.

With the battery unplugged but the radio turned on... and the prop on the motor removed ( for safety just in case ).
Raise your throttle to full throttle on the radio.
Plug your battery in on the airplane
Lower your throttle to the lowest setting on the radio.

In most cases, that will calibrate it and allow the ESC to arm ( or activate for another word for it, usually you'll hear some tones from the motor if it does ). If not, the trim for the throttle on the radio may need lowered... try clicking it one click at a time and repeat it until the ESC finally arms during the calibration steps I mentioned.

As I also mentioned, not all ESC's use those exact steps. If yours isn't arming... read the manual for your ESC to find out the steps. Please note that the ESC must sense a zero throttle setting also for it to arm so you may need to tweak the trim until that happens. I'd also suggest counting the number of times you click the trim down in case you need to get back to where you started at.
 

GoFlyBoy

New Member
I am sooooo close. I can’t get the ESC to do its thing.
Using now my FUTABA 10CAG with a R617FS receiver.
Had to change the transmitter to 7ch Mode.
It did bind …. Bust still no motor. Lots of beeping
 

RandyDSok

Well-Known Member
You'll need to find the instructions for the ESC at that point... it shouldn't matter that the trans. is in 7ch or not as long as it bound to the receiver... it's all in how you calibrate the ESC and where the low throttle setting is at now.
 

GoFlyBoy

New Member
This is what I did (from support)



1). First thing before we start take the prop off! On Futaba, the throttle channel is normally reversed. you will need to reverse your throttle channel on your radio then fire up the model and see if it arms.

2). you can also do an ESC calibration. with the plane unplugged place, your throttle at full plug in the airplane the ESC should beep two times then lower the throttle to zero should get 6 beeps then its arm. also just to make sure are you using a 4s or 6s battery if you are using anything less it will not arm.



It worked
 

GoFlyBoy

New Member
I just purchased the new updated landing gear.
Thanks for checking in. All works great now.
bit of a messed up landing. Broke prop. Waiting for new one
 

Top Bottom