• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Quad Threshold / timed boost? Help?

DeepSeaOrca42

New Member
So I'm finding out that if I go "so" high with my throttle motors start to accelerate irregularly sometimes. Oddly enough power isn't always evenly distributed across the board. Nor is it one motor over the other or even a set of motors over the others. I think I'm narrowing it down to a faulty accelerometer? But then it seems to figure itself out sometimes if / when I reboot... The problem being I don't know until I'm in the air, if when the problem will strike. It's like trying to fly with a bomb on your back.? I'm this close to begin to fly this thing with a string tied around it like a kite. I've updated the firmware on the FC & ESC to current versions. Amazed I haven't broken an arm yet, but I guess the Emax Buzz frame is built pretty sturdy. I'm also attempting to wrestle with blackbox data. So far I'm not really seeing enough data out of it to justify turning it on? I was thinking if I turned it on durring a flight I could see from inside what had happened to cause such actions? Ideas? Help? So far I've been flying under a foot off the ground. I've kept my finger on the disarm button & thankfully it drops then. So it's falling maybe 8-20 feet from the air.
 

RandyDSok

Well-Known Member
You really should provide a detailed list of the specific parts, models etc that you have questions about... If you had posted those previously in a different thread, don't make someone that would otherwise try to help you, have to search for that info when you already know what that is.
 

DeepSeaOrca42

New Member
I'm using a Magnum F7 FC (current firmware v4.2.9), with a BL Heli ESC (current firmware v32.8), XM+ radio stock, Jumper T Lite transmitter. All this is stock Emax Buzz stuff. VTX has never even been turned on (Still flying around in short order with the lens cap on.) Sad huh?
 
Last edited:

RandyDSok

Well-Known Member
Sometimes what version number firmware you have makes a difference and using the latest may introduce problems... so saying "current version" really isn't specific enough if one of those cases happens ( or someone reads this later after another version comes out perhaps ). I'm not trying to sound picky here... but technical details really are that important. I also don't do ( or even like ) quads etc, so this info isn't for me... its for others that are into these things and what they'll need in order to help.
 

RandyDSok

Well-Known Member
I've just remember something I'd read concerning a heli's gyro and how it's mounted. The one in question was acting erratically but had been working fine for a long time, it turned out that the double sided foamy tape had gotten old and brittle, after replacing it with new, the problems went away. I'd assume different systems have different requirements but it can't hurt to suggest going back over the instructions on how to mount that board and make sure it is done like the manual suggested and isn't loose or too tight ( if that matters in this case ).
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
RDS is correct. I had the same problem. Never even cross my mind on the tape. Even Geena suggested, to me, that you should your double sided tape once a year. Especially here in FLA where the sun isn't nice to plastic lol.
 

Top Bottom