• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Site Went Down, Again, Sorry About That

Tony

Administrator
Staff member
When I went to bed last night, the site was running fine. When I got up, I had emails and messages out the wazoo about the site being down. I have corrected the issue and hopefully this doesn't happen again. Sorry about that.
 

Tony

Administrator
Staff member
And once again. I was cleaning up some bad tables and it went down again. Hopefully this time, everything is up and running and will stay that way for a while.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
What can you do Tony. :censored: happens... welcome to the wonderful world of electronics, I always say:disgust:
 

Tony

Administrator
Staff member
I am looking into why the site went down again. It was the same issue as before and I think I know the issue. That is twice it has went down on a Saturday morning. Nothing like waking up to a site not working lol
 

Tony

Administrator
Staff member
I'm working on it guys. What I thought was causing it is completely disabled right now, so I'm having to look elsewhere. Sucks that it only happens once a week...
 

Tony

Administrator
Staff member
It's getting old, I know. Every week I'm making a change to see what in the hell is going on with the server and when I make a change, I have to wait a week for it to do it again to narrow it down. This time, I'm not waiting because I'm getting rid of a lot of add on's for the site in hopes that this never happens again. I know you guys are tired of it, I am darn sure tired of it and we all just want the issue resolved. I'm working on it everyone.
 

Tony

Administrator
Staff member
Thanks to Ken running his Linux Voodoo, we have found the issue and have made changes to fix it. I now know exactly what time the server is crashing and I will be looking for it for the next few weeks. We are working on it and we are now a lot closer to having the issue resolved.
 

Tony

Administrator
Staff member
something in the database is running out of resources. We are working on the issue.
 

Tony

Administrator
Staff member
I know right... The issue all along has been the database name. Instead of rc_forumDatabase we had rc.forumDatabase. Since we had a . and not an _ it killed everything when it tried to do a weekly integrity check. We fixed that yesterday, but today we found the database table issue after a mariadb update which was causing all kinds of issues. Basically, if you use a period, it thinks anything before it is the database name, and anything after it is the table name when in fact it was ALL the table name. So we have made that change and things should be good. If anyone sees anything janky, please let me know.
 

Top Bottom