1. If you would like to get rid of these banners and the ads within the posts, all you have to do is sign up and they will go away!
  2. Hey Guest, are you here looking for the PDF Plans? They are located in the store in the tab above, but you must be signed in to access that part of the site. It only takes a second to sign up!
Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Boats Old traxxas

Discussion in 'Cars, Trucks, Boats' started by Ken Steinbach, Sep 5, 2017.

  1. Ken Steinbach

    Ken Steinbach New Member

    Blog Posts:
    0
    Joined:
    Sep 3, 2017
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Federal Way WA
    I have a older traxxas that uses 2 nimh batteries and 4 aaa. I cant get anythi g to work. Contoller batt are good. The 2 nihm are good. It worked when i used it last but now nothing.
    Its a cool boat and want to play before summers over in Seattle.
    Help
     


  2. Ken Steinbach

    Ken Steinbach New Member

    Blog Posts:
    0
    Joined:
    Sep 3, 2017
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Federal Way WA
    Villian is the boat.
     
  3. Ken Steinbach

    Ken Steinbach New Member

    Blog Posts:
    0
    Joined:
    Sep 3, 2017
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Federal Way WA
  4. Tony

    Tony Administrator Staff Member

    Blog Posts:
    10
    Joined:
    Feb 21, 2011
    Messages:
    31,873
    Likes Received:
    1,205
    Trophy Points:
    113
    I could have sworn I replied to this thread lol.

    Are all of those batteries working together? Have you checked the voltage on each cell?
     
  5. tntpoof

    tntpoof Member

    Blog Posts:
    0
    Joined:
    Jan 24, 2017
    Messages:
    30
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Taylor,MI.
    I would start by making sure all is working from esc to motor..test them..charge batteries test voltages.. disconnect motors then use a D cell on each motor to see if it turns.. then check esc.. My guess is either esc is dead or bec on esc is..does rx light come on when u turn all on ..esc and radio(1st)..trouble shoot all..if esc bec is dead then use 4 AA's to power rx and servo..if this is a 2.4 system then check bind ..rebind rx to radio..
     

Share This Page