1. If you would like to get rid of these banners and the ads within the posts, all you have to do is sign up and they will go away!
  2. Welcome to Rc-Help, are you here looking for the PDF Plans? They are located in the store in the tab above, but you must be signed in to access that part of the site. It only takes a second to sign up!
  3. Like Us On Facebook!
    Hello Guest, it occurred to us during that last server failure that we had no way of informing the members of the site of the failure and I would like to invite you to like us on facebook so that you can get updates if the site happens to go down again. We don't post much over there unless we are updating the members so we will not flood your feed like some places do. Just click on Like and then allow notifications and that's it. See you there soon!

    Click Here To Rc-Help's Facebook page!
    Dismiss Notice
Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Quad Emax Babyhawk

Discussion in 'Multi-Rotor' started by sneezy007, Mar 12, 2018.

  1. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    Hey guys,

    I was working on my Babyhawk yesterday and I ran into problems with Betaflight. On the receiver page, there are no bars. I have a green light on my receiver. I'm using the FrSky XM+, the motors spin up and everything else works on Betaflight. I tried resetting the settings in Betaflight, tried to rebind. Nothing works.

    Does anyone have any ideas?

    Thanks,
    Dino
     


  2. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    In the configuration tab, do you have it all set for your receiver? Also, in the ports tab, do you have the right switches turned on?
     
  3. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    You bet Tony, I double checked all of those things. What's weird is there is a green light on the receiver, but it's like it's not talking to my radio.

    Thanks,
    Dino
     
  4. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    Yea, that is weird. Have you taken that receiver (if it is a sat) and connected it to an actual receiver and tried to bind it that way?

    Also if you can post up some screen shots of your betaflight/cleanflight config, that may help out a little as well.
     
  5. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    Actually Tony the XM+ is a receiver. Sure I'll do that next time I'm in Betaflight.
     
  6. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    I'm so used to just using satellites lol.

    Where do you have your signal wire going from the receiver?
     
  7. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    So I know nothing about sbus, but I just watched a video on it and found something out that could be the issue. If you are running an F4 board, you may be on a UART that doesn't have a converter. Solution here is to try the other UART's and see if those work. In your ports tab, make sure that the UART you are using has serial Rx turned on and in the config tab, make sure you are set to sbus/spektrum and select sbus from the dropdown. You may need to do those last two steps a few times for it to save since betaflight likes to revert them once in a while. But I do believe if you do the port and then the receiver under config that it should save first try.

    I know, you said you had already checked these, I'm just typing what I found out in another video.
     
  8. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    Well actually with the XM+ you solder the receiver right onto the Femto board. It has a pin out, I doubled the pinout and instructions on the receiver to make sure I soldered it correctly. I'll have to check if the Femto board is an F4. It defaults to UART3 when you fire up Betaflight. Let me check this out and see what happens. Thanks Tony.
     
  9. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    Is this the board you have? If so, then it is an F3 board and what I posted doesn't mean a thing lol.

    emax-f3-femto-flight-controller.jpg
     
  10. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    The Babyhawk has the Femto board. The firmware is the SPRACING F3 EVO.
    I may have to update the firmware and see if that helps.
     
  11. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    I updated the firmware and everything worked. I even hovered it in the basement and it flies great.
    Now we just need to wait for the snow to melt so we can head to the field.
     
  12. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    That's great news. Glad you got it working.
     
  13. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    It takes me awhile to do the trouble shooting. I have to ask lots of questions, eventually I get there.

    Thanks for your help Tony.
    Dino
     
  14. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    It's my pleasure bro! I thought it was going to be much tougher than just reflashing lol.
     
  15. sneezy007

    sneezy007 I Support Rc-Help! Rc-Help Supporter

    Joined:
    Feb 11, 2016
    Messages:
    372
    Likes Received:
    14
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Geophysical Technician (Retired)
    Location:
    Calgary, Alberta, Canada
    Home Page:
    Some times the most obvious solutions are the ones we think of last...lol
     
  16. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 21, 2011
    Messages:
    33,256
    Likes Received:
    1,284
    Trophy Points:
    113
    haha, you are exactly right about that.
     

Share This Page