• Hey Guest, I see you are not signed up on our forum yet. Did you know Registration is FREE and is only a couple clicks away? You can even sign in from Facebook, Twitter or Google+ for your convenience! So what are you waiting for, CLICK HERE to join in on the conversation!

Early Morning Flight :)

D.O.G.

Well-Known Member
Goblin 380 Supporter
First time I drove by my self to the park to fly :) IMG_4266.JPG The Gaui X3L few fine but the 500 had a minor problem but could of been a tragic flight. The X3l was fun. I need to go to the park more often since I'm on the road again after 10 1/2 yrs :).
 

Tony

Administrator
Staff member
Great flight, much more room than in your yard lol. And nice catch on that 500!
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
I headed out this morning to the flying softball field again with my 500, X3l and my first built foam plane IMG_4274.JPG . This is also my first time ever flying a plane. Of course the 500 tail servo acted up again after 2 minutes into the flight. I hope that the new tail servo coming will solve this problem. I just don't know what else it could be. The push rod and holders are just fine. Only happens when the servo seem to get hot. Here's the 500. I'm not sure you can tell what's going on but it's near the end of the video Here the X3l flying well like always Here's my first flight with my first built foam plane. My settings need to be tame down some and I need to learn how to fly a plane vs a heli Lol. All went well til my motor fell off. The o ring that holds the prop on didn't break. The prop didn't come off. The motor just fell off...oh well! Here's the pic of the plane when I went to get it IMG_4282.JPG
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Looks like your making the most of your good weather and your license.

Yes sir Admiral. You don't know what you have til you loose it :(. Nobody fault but my own but I'm glad that I got a second chance. 10 yrs + is a long time.
 

Tony

Administrator
Staff member
are you running a governor on that X3? At the 3:15 mark it seemed to bog really bad.

On the 500, I couldn't see anything other than some very wide hunting on the tail, but you could have been doing that with the sticks.

As for the plane, need more hot shmoo!!!! lmao. And next time, take the air brakes off the wings. It will fly a lot better. It also looked like it was a touch too nose heavy. Either way, looks like you had a blast and congrats on your first plane. You may be buying this plane that I"m about to receive. I think it's going to be awesome.
 

Tony

Administrator
Staff member
And also, the prop didn't sound balanced on the plane. Sounded like there was a lot of vibration that could have lead to the motor failure. Might check that before the next flight. Yes, "next flight" because foam plane, all you need is a little hot glue lol.
 

D.O.G.

Well-Known Member
Goblin 380 Supporter
Hey Tony. On the X3L I am running a governor. I notice the bogging down when I was flying. I'll have to check the setting on the HW esc. As for the 500, the tail isn't hunting. I was trying to get the tail to respond to my stick command. That's been my problem all this time. The tail servo seem to have a mind of it's own Lol. My new tail servo will be here Tuesday so I hope that will solve my problem...will see. Your absolutely right about I need more hot shmoo. I do have the motor back on the plane and the shmooo was applied very well :). NOOOO! I don't want another plane. I'm a heli man all the way. Quads are fun in FPV flight because I feel like I'm right in there flying.The plane was just something I wanted to try out since I never build or flew a plane before and beside the electronics, it only cost me $3.00 for the foam at dollar tree. I will check the balance of the prop and the CG of the plane. This is all new to me. I know you will be there to help me out when I need it and I'm sure I will :).
 

Top Bottom